using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{14} - - \[[^\]]+\] ""\S+ \S+ HTTP\/[^""]+"" \S+ \S+";
string input = @"210.168.71.159 - - [12/Oct/2015:00:05:30 +0900] ""GET /bbs/view.php?board_id=kor_notice&gul_no=863&idx=16&m=4&upage=25&gul_no=5304&page=1 HTTP/1.1"" 200 4218";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}