import Foundation
let pattern = #"^.{14} - - \[[^\]]+\] "\S+ \S+ HTTP\/[^"]+" \S+ \S+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"210.168.71.159 - - [12/Oct/2015:00:05:30 +0900] "GET /bbs/view.php?board_id=kor_notice&gul_no=863&idx=16&m=4&upage=25&gul_no=5304&page=1 HTTP/1.1" 200 4218"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)