const regex = /^([^{]*)\$\{([^}]*)\}([^{]*)\$\{([^}]*)}(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^{]*)\\$\\{([^}]*)\\}([^{]*)\\$\\{([^}]*)}(.*)$', 'gm')
const str = `cnt=\$(( \${cnt} + \${cnt123} ))`;
const subst = `$1$2$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);