$re = '/^([^{]*)\$\{([^}]*)\}([^{]*)\$\{([^}]*)}(.*)$/m';
$str = 'cnt=$(( ${cnt} + ${cnt123} ))';
$subst = "$1$2$3$4$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;