re = /^([^{]*)\$\{([^}]*)\}([^{]*)\$\{([^}]*)}(.*)$/m
str = 'cnt=$(( ${cnt} + ${cnt123} ))'
subst = '$1$2$3$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result