use strict;
my $str = 'Design No. TAHN-7075 Natural Gray 0997-101 White 0911-101
Design No. TAHN-7082(CS-02) Natural Gray 0997-101 Natural Gray 0997-101
Design No. TAHN-7082(CS-02) Natural Gray test 0997-101 Natural Gray abc Def 0997-101';
my $regex = qr/\b([A-Z]{2,}-\d+(?:\([^)]+\))?)\s+([a-zA-Z]+(?:\s+[a-zA-Z]+)+)*\s+\d+-\d+\s+([a-zA-Z]+(?:\s+[a-zA-Z]+)*)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}