import Foundation
let pattern = #"\b([A-Z]{2,}-\d+(?:\([^)]+\))?)\s+([a-zA-Z]+(?:\s+[a-zA-Z]+)+)*\s+\d+-\d+\s+([a-zA-Z]+(?:\s+[a-zA-Z]+)*)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Design No. TAHN-7075 Natural Gray 0997-101 White 0911-101
Design No. TAHN-7082(CS-02) Natural Gray 0997-101 Natural Gray 0997-101
Design No. TAHN-7082(CS-02) Natural Gray test 0997-101 Natural Gray abc Def 0997-101
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)