$re = '/\b([A-Z]{2,}-\d+(?:\([^)]+\))?)\s+([a-zA-Z]+(?:\s+[a-zA-Z]+)+)*\s+\d+-\d+\s+([a-zA-Z]+(?:\s+[a-zA-Z]+)*)\b/m';
$str = 'Design No. TAHN-7075 Natural Gray 0997-101 White 0911-101
Design No. TAHN-7082(CS-02) Natural Gray 0997-101 Natural Gray 0997-101
Design No. TAHN-7082(CS-02) Natural Gray test 0997-101 Natural Gray abc Def 0997-101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);