using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bzip\b\D*\d{5}(?:\s+\d{5})*\b";
string input = @"zip you have some thing 70456 90876 78905 text...
zip 123456 56789";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}