// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bzip\b\D*\d{5}(?:\s+\d{5})*\b").unwrap();
let string = "zip you have some thing 70456 90876 78905 text...
zip 123456 56789";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}