const regex = new RegExp('\\bzip\\b\\D*\\d{5}(?:\\s+\\d{5})*\\b', 'gm')
const str = `zip you have some thing 70456 90876 78905 text...
zip 123456 56789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}