#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:(?!\s|=).)*)\s*?=\s*?["']?((?:(?<=")(?:(?<=\\)"|[^"])*|(?<=')(?:(?<=\\)'|[^'])*)|(?:(?!"|')(?:(?!\/>|>|\s).)+))"
Local $sString = "<a href=test.html target=xyz>" & @CRLF & _
"<a href=test.html target=xyz/>" & @CRLF & _
"<a href=test.html target=xyz />" & @CRLF & _
"<a href="test.html" target="xyz">" & @CRLF & _
"<a href='test.html' target="xyz">" & @CRLF & _
"<a href="test.html?val=1" title="Charlie's Angels \"test\" cool! "> " & @CRLF & _
"<a href = "test.html?val=1" title='Charlie\'s Angels'> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")