re = /((?:(?!\s|=).)*)\s*?=\s*?["']?((?:(?<=")(?:(?<=\\)"|[^"])*|(?<=')(?:(?<=\\)'|[^'])*)|(?:(?!"|')(?:(?!\/>|>|\s).)+))/
str = '<a href=test.html target=xyz>
<a href=test.html target=xyz/>
<a href=test.html target=xyz />
<a href="test.html" target="xyz">
<a href=\'test.html\' target="xyz">
<a href="test.html?val=1" title="Charlie\'s Angels \\"test\\" cool! ">
<a href = "test.html?val=1" title=\'Charlie\\\'s Angels\'> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end