$re = '/((?:(?!\s|=).)*)\s*?=\s*?["\']?((?:(?<=")(?:(?<=\\\\)"|[^"])*|(?<=\')(?:(?<=\\\\)\'|[^\'])*)|(?:(?!"|\')(?:(?!\/>|>|\s).)+))/';
$str = '<a href=test.html target=xyz>
<a href=test.html target=xyz/>
<a href=test.html target=xyz />
<a href="test.html" target="xyz">
<a href=\'test.html\' target="xyz">
<a href="test.html?val=1" title="Charlie\'s Angels \\"test\\" cool! ">
<a href = "test.html?val=1" title=\'Charlie\\\'s Angels\'> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);