$re = '/\b(?!(?:váš|Váš|náš|Náš)\b)\w*eš\b|íš\b|áš\b/m';
$str = 'Náš počítač je ideální společník na cesty.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);