re = /\b(?!(?:váš|Váš|náš|Náš)\b)\w*eš\b|íš\b|áš\b/m
str = 'Náš počítač je ideální společník na cesty.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end