const regex = /^.*?(?=\s*(?:Part1|Part2|Part3|Part4))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(?=\\s*(?:Part1|Part2|Part3|Part4))', 'mg')
const str = `MatchOnlyMe! Part1 Part2 Part3 Part4
MatchOnlyMe! Part2 Part3 Part4
MatchOnlyMe! Part2 Part3
MatchOnlyMe! Part1 Part3 Part4
MatchOnlyMe! Part3 Part4
MatchOnlyMe! Part4
MatchOnlyMe! Part2
MatchOnlyMe! Part2 Part4
MatchOnlyMe! Part1 Part4
MatchOnlyMe! Part1 Part2 Part4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}