using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?:\/\/)?(www\.)?((?!www)[A-Za-zА-Яа-яЁё0-9\.\-]{2,})\.(.+)$";
string input = @"https://wwtest.ru?12323dsfdfdsfdsf+-*-+";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}