$re = '/^(https?:\/\/)?(www\.)?((?!www)[A-Za-zА-Яа-яЁё0-9\.\-]{2,})\.(.+)$/m';
$str = 'https://wwtest.ru?12323dsfdfdsfdsf+-*-+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);