import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\((?=[^)\\/]*\\))[^)\\/]+\\)";
final String string = "/(auth)/login\n"
+ "/(dashboard)/settings\n"
+ "/(auth-v2)/login\n"
+ "/(api_internal)/api\n"
+ "/(v2.0.beta)/features\n"
+ "/(marketing)/public/about\n"
+ "/some/(auth)/path/(dashboard)/more\n\n\n\n"
+ "/(aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa)/very-long-group-name\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}