re = /\/\((?=[^)\/]*\))[^)\/]+\)/
str = '/(auth)/login
/(dashboard)/settings
/(auth-v2)/login
/(api_internal)/api
/(v2.0.beta)/features
/(marketing)/public/about
/some/(auth)/path/(dashboard)/more
/(aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa)/very-long-group-name
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end