$re = '/\/\((?=[^)\/]*\))[^)\/]+\)/';
$str = '/(auth)/login
/(dashboard)/settings
/(auth-v2)/login
/(api_internal)/api
/(v2.0.beta)/features
/(marketing)/public/about
/some/(auth)/path/(dashboard)/more
/(aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa)/very-long-group-name
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);