# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@\K.+/$0", acct.$0);/gm;t' <<< "command.Parameters.Add(\"@Id
command.Parameters.Add(\"@IsDeleted
command.Parameters.Add(\"@MasterRecordId
command.Parameters.Add(\"@Name"