$re = '/(?<=\;|^)(.+?)\;(?=(.+\;)?\1(\;|$))/';
$str = 'ABC;ABC;XYZ;PQR;ABC;PQR';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;