re = /(?<=\;|^)(.+?)\;(?=(.+\;)?\1(\;|$))/
str = 'ABC;ABC;XYZ;PQR;ABC;PQR'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result