$re = '/<[^>]+>|([^,]+)(,[ ]*\1)+/';
$str = 'Administrator System, Administrator System, Administrator System, Administrator System, Administrator System, ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;