re = /<[^>]+>|([^,]+)(,[ ]*\1)+/
str = 'Administrator System, Administrator System, Administrator System, Administrator System, Administrator System, '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result