import re
regex = re.compile(r"<[^>]+>|([^,]+)(,[ ]*\1)+")
test_str = "Administrator System, Administrator System, Administrator System, Administrator System, Administrator System, "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)