const regex = new RegExp('\\b(?:[89]|1[0-3])/(?:[0-9]|1[0-5])\\b', 'gm')
const str = `Enter a slot/port : 8/2
Enter a slot/port : 1/0
Enter a slot/port : 8/15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}