use strict;
my $str = 'Enter a slot/port : 8/2
Enter a slot/port : 1/0
Enter a slot/port : 8/15';
my $regex = qr/\b(?:[89]|1[0-3])/(?:[0-9]|1[0-5])\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}