using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(...)(?=.)";
string substitution = @"$1\r\n";
string input = @"saahaalaa";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}