use strict;
my $str = 'saahaalaa';
my $regex = qr/(...)(?=.)/mp;
my $subst = '$1\\r\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";