$re = '/(...)(?=.)/m';
$str = 'saahaalaa';
$subst = "$1\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;