$re = '/(?:email":\["|\G(?!\A)",")\K[^"]+/m';
$str = 'dias","telephone":"","email":["wsd@gmail.com","info@site.ee","m@ya.ru"],"address":{"@type":"PostalAddress",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);