re = /(?:email":\["|\G(?!\A)",")\K[^"]+/m
str = 'dias","telephone":"","email":["wsd@gmail.com","info@site.ee","m@ya.ru"],"address":{"@type":"PostalAddress",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end