use strict;
my $str = '\\only{
\\begin{equation*}
\\psi_{w}(B)(1-B)^{d}y_{t,w} = x^{T}_{t,w}\\gamma_{w} + \\eta_{w}(B)z_{t,w},
\\label{eq:gen_arima}
\\end{equation*}
}
\\only{
}';
my $regex = qr/\\only\s*({((?:[^{}]++|(?1))*)})/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";