// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\only\s*({((?:[^{}]++|(?1))*)})").unwrap();
let string = "\\only{
\\begin{equation*}
\\psi_{w}(B)(1-B)^{d}y_{t,w} = x^{T}_{t,w}\\gamma_{w} + \\eta_{w}(B)z_{t,w},
\\label{eq:gen_arima}
\\end{equation*}
}
\\only{
}";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}