$re = '/\\\\only\s*({((?:[^{}]++|(?1))*)})/';
$str = '\\only{
\\begin{equation*}
\\psi_{w}(B)(1-B)^{d}y_{t,w} = x^{T}_{t,w}\\gamma_{w} + \\eta_{w}(B)z_{t,w},
\\label{eq:gen_arima}
\\end{equation*}
}
\\only{
}';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;