#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([1-3]|[A-C])(\.|\))"
Local $sString = "1. Something" & @CRLF & _
"2. Test 2" & @CRLF & _
"3) Else A" & @CRLF & _
"A) 123 (yes.)" & @CRLF & _
"Something B) Test" & @CRLF & _
"C) Test C)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")