$re = '/([1-3]|[A-C])(\.|\))/m';
$str = '1. Something
2. Test 2
3) Else A
A) 123 (yes.)
Something B) Test
C) Test C)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);