const regex = /([1-3]|[A-C])(\.|\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-3]|[A-C])(\\.|\\))', 'gm')
const str = `1. Something
2. Test 2
3) Else A
A) 123 (yes.)
Something B) Test
C) Test C)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}