use strict;
my $str = 'My number is 212-345-9999.
';
my $regex = qr/(?<!\S)(\d{3})-/mp;
my $subst = '(\\1) ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";