import Foundation
let pattern = #"(?<!\S)(\d{3})-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
My number is 212-345-9999.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1) "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)