$re = '/(?<!\S)(\d{3})-/m';
$str = 'My number is 212-345-9999.
';
$subst = "(\1) ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;