using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?.+";
string input = @"https://www.chytryhonza.cz/hypoteka?utm_source=CeskeReality.cz&utm_medium=textovy_odkaz&utm_campaign=dis%7Chypo%7Caffiliate%7Ctextovy_odkaz&utm_content=nejvyhodnejsi_hypoteka&amount=1208648&property_price=1510810
https://www.chytryhonza.cz/hypoteka
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}