re = /\?.+/m
str = 'https://www.chytryhonza.cz/hypoteka?utm_source=CeskeReality.cz&utm_medium=textovy_odkaz&utm_campaign=dis%7Chypo%7Caffiliate%7Ctextovy_odkaz&utm_content=nejvyhodnejsi_hypoteka&amount=1208648&property_price=1510810
https://www.chytryhonza.cz/hypoteka
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end