import Foundation
let pattern = #"\?.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.chytryhonza.cz/hypoteka?utm_source=CeskeReality.cz&utm_medium=textovy_odkaz&utm_campaign=dis%7Chypo%7Caffiliate%7Ctextovy_odkaz&utm_content=nejvyhodnejsi_hypoteka&amount=1208648&property_price=1510810
https://www.chytryhonza.cz/hypoteka
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)