# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(,[^\]\[,]*\[[^\]\[]*])[^?]*\?/$1/gm;t' <<< "Together, Let's End Their War: Promoting a Culture of Health among Veterans on the Gulf - How strongly do you value your relationship with [Field-2]?
Together, Let's End Their War: Promoting a Culture of Health among Veterans on the Gulf - During the Clinical Scholars Program, with [Field-2], have you partnered new project(s) other than your team's Wicked Problem Impact Project?"