const regex = /(,[^\]\[,]*\[[^\]\[]*])[^?]*\?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,[^\\]\\[,]*\\[[^\\]\\[]*])[^?]*\\?', 'gm')
const str = `Together, Let's End Their War: Promoting a Culture of Health among Veterans on the Gulf - How strongly do you value your relationship with [Field-2]?
Together, Let's End Their War: Promoting a Culture of Health among Veterans on the Gulf - During the Clinical Scholars Program, with [Field-2], have you partnered new project(s) other than your team's Wicked Problem Impact Project?`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);