$re = '/(,[^\]\[,]*\[[^\]\[]*])[^?]*\?/m';
$str = 'Together, Let\'s End Their War: Promoting a Culture of Health among Veterans on the Gulf - How strongly do you value your relationship with [Field-2]?
Together, Let\'s End Their War: Promoting a Culture of Health among Veterans on the Gulf - During the Clinical Scholars Program, with [Field-2], have you partnered new project(s) other than your team\'s Wicked Problem Impact Project?';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;